Skip to main content
❓ Question
Asked a question 5 months ago

hello! I have 2 ottos (a starter edition and a ninja humanoid) but I can't figure out why I can't upload code to either of them. The starter one uploads with no errors, then twitches once and never again. No sounds. The ninja gives me errors uploading examples, like this:Error: Command failed: arduino-cli.exe upload --port COM3 --fqbn esp8266:esp8266:nodemcuv2 sketch/sketch.ino Traceback (most recent call last): File "C:\OttoBlockly\compilation\arduino\packages\esp8266\hardware\esp8266\2.7.4/tools/upload.py", line 65, in esptool.main(cmdline) File "C:/OttoBlockly/compilation/arduino/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py", line 2933, in main detect_flash_size(esp, args) File "C:/OttoBlockly/compilation/arduino/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py", line 2241, in detect_flash_size flash_id = esp.flash_id() File "C:/OttoBlockly/compilation/arduino/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py", line 607, in flash_id return self.run_spiflash_command(SPIFLASH_RDID, b"", 24) File "C:/OttoBlockly/compilation/arduino/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py", line 853, in run_spiflash_command old_spi_usr = self.read_reg(SPI_USR_REG) File "C:/OttoBlockly/compilation/arduino/packages/esp8266/hardware/esp8266/2.7.4/tools/esptool\esptool.py", line 490, in read_reg val, data = self.command(self.ESP_READ_REG, struct.pack('

For more content join our community, sign up and become an Otto Builder now!