Skip to main content
❓ Question
Arduino
Asked a question 5 months ago

Hi! Im totally new in this world... My Ninja doesnt start. I connected all right, so the told me i should reinstall the "App Code Arduino". I made all how the Video and the "Otto Ninja 101" told me, but during upload comes this message: Can you help me please! Thanks and sorry for my english... "Arduino: 1.8.19 (Windows 10), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, Disabled (new aborts on oom), Disabled, All SSL ciphers (most compatible), 32KB cache + 32KB IRAM (balanced), Use pgm_read macros for IRAM/PROGMEM, 4MB (FS:2MB OTA:~1019KB), 2, v2 Lower Memory, Disabled, None, Only Sketch, 115200" Multiple libraries were found for "Servo.h" In file included from C:\Users\marti\OneDrive\Dokumente\Arduino\libraries\OttoNinja-master\src\Adafruit_GrayOLED.cpp:20: Used: C:\Users\marti\AppData\Local\Arduino15\packages\esp8266\hardware\esp8266\3.0.2\libraries\Servo C:\Users\marti\OneDrive\Dokumente\Arduino\libraries\OttoNinja-master\src\Adafruit_GrayOLED.h:30:10: fatal error: Adafruit_I2CDevice.h: No such file or directory Not used: C:\Program Files (x86)\Arduino\libraries\Servo 30 | #include <Adafruit_I2CDevice.h> | ^~~~~~~~~~~~~~~~~~~~~~ compilation terminated. exit status 1 Error compiling for board NodeMCU 1.0 (ESP-12E Module). This report would have more information with "Show verbose output during compilation" option enabled in File -> Preferences. "

For more content join our community, sign up and become an Otto Builder now!